SIG Sauer 556 Arms Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Greetings! I picked up a Sig 556 SWAT a couple of years ago and it is hands down one of my favorite guns. I have only shot it a couple of times but the feel and aesthetics have always drawn me in since I was a kid.

The last time I shot it, I tried running my YHM Turbo 5.56 suppressor on it and it did not perform well. With the gas block wide open, it viciously cycled rounds and would actually crimp/dent the casing towards the bottom of the round, eventually leading to a failure to feed. When running in the "suppressed mode", the gun was very quiet but did not cycle a round at all - I would have to manually cycle a round after each shot.

Cleary the gun is too over gassed with the 10" barrel configuration. Has anyone ever modified their gas block to alleviate some of these issues? I was told by a range office that a specific company will actually drill the gas ports out or add an extra port to the existing block, specifically for the 556, but I cant remember the name of the company.

Any suggestions on this is appreciated. Also, I am fully aware that 5.56 does not suppress well and these guns are not the best to run suppressed - I am just wondering if there is a way to set it up since I enjoy shooting my guns suppressed and it looks way cooler.
 

·
Registered
Joined
·
370 Posts
I am fully aware that 5.56 does not suppress well and these guns are not the best to run suppressed...
Huh... I have yet to run my 10" 556xi suppressed, but it does have a setting specifically for rolling a suppressor. Never had any issues suppressing the 16" barrel in 551 (not patrol) gas piston length/config. I also have a new P556. Again no testing with a suppressor yet. I know there is a member here that used to offer a service for drilling additional suppressor ports in your gas valve. Not sure if he is still around? Additionally, JDi used to offer the 4 position valve for the 552/3 but they have been on backorder for as long as I can remember... https://www.shop.jdifirearms.com/4-Position-Gas-Valve-for-SG-552-3-SAN34554937.htm
 

·
Registered
Joined
·
51 Posts
I've also not yet shoot my 10" SIG SWAT suppressed, but have looked into this issue.

The thread that @LKY13 mentioned in his post above is here (link below). The member is @Z32MadMan his email address is on the attachment at post #37 of that thread. Not sure if he's still doing them.

He also posted on AR15.com
and SIG Talk

Those threads are worth the read even if @Z32MadMan isn't doing it any more. Plenty of great info to DIY.
 

·
Registered
Joined
·
8 Posts
Hey Sam,
So I’ve had my 556 with the 10.5” barrel for almost a decade now. I first shot it with an AAC M4-2000 suppressor about 4 years back. I had a similar experience as you described with the rifle being over gassed but I didn’t experience any failures of any kind. The rifle would just eject casings 40+ feet. For reference the M4-2000 suppressor is really bad with back pressure.

I was not aware and still don’t believe these guns have a suppressor setting but I have not actually used a pin gauge to measure the two factory gas ports to confirm what I believe.

The way I solved this problem was, while researching I found a guy on an old forum that would modify the gas valves by essentially mirroring the location of the two gas ports, but when adding the new ones he just used smaller holes.

He set me up with a “degassed” setting and a suppressor setting. The results really surprised the heck out of me. “Degassed” setting has the ejection at approximately 10’ to the 2 o’clock position, I would describe it as perfect. The suppressed setting is the same, I would call it perfect.

The guy who did the work for me was great to work with however I’m a stickler for this kind of machine work. It appears he did the work with a basic end mill or a drill press so the machine work itself leaves me wanting to do it again but I want to have my friend who is a machinist recreate it.

I have a second gas valve laying around. So what I plan to do on the near future is have my friend use a pin gauge to measure the port sizes in the valve I had worked on, then he will locate the new port holes and essentially recreate the part that I know works perfectly.

If it turns out to be a success using my buddy, I will get back on here and get the two of you in contact. I’m sure for a small few he would help you out.

Feel free to reach out and send me an email and we can discuss it further.
[email protected]
 
1 - 4 of 4 Posts
Top